Actualización: Solo unas horas después de que qwertyoruiop publicase el exploit en el kernel 4.55 de PlayStation 4 ha aparecido una vulnerabilidad en el webkit que afecta hasta la versión 5.05. En otras palabras, los propietarios de una PlayStation 4 con firmware 4.55 pueden disfrutar de las ventajas y beneficios de la scene.

Ahora que la puerta del webkit se ha abierto hasta el firmware 5.05 toca la parte difícil, encontrar una vulnerabilidad en esta versión del kernel. Cuando esto suceda la scene podrá atacar con éxito a todas las PlayStation 4 existentes, ya que esta versión del software del sistema pasa por ser la más reciente lanzada por Sony. De nuevo parece que solo es cuestión de tiempo.

Noticia original: La scene de PlayStation 4 ha dado un nuevo paso después de que el reconocido hacker qwertyoruiop haya liberado el código de una vulnerabilidad en el kernel 4.55 de PlayStation 4. Al contrario de lo que pueda parecer (aún) no se trata de la noticia que esperaban los usuarios con una consola en esta versión del software del sistema, pero los que se hayan quedado en la 4.06 y 4.07 ya pueden empezar a cantar victoria.

Técnicamente esta vulnerabilidad en el kernel afecta hasta el firmware 4.55 de PlayStation 4, sin embargo para ejecutarlo hace falta un punto de entrada. Actualmente el único pie en la puerta es un exploit en el webkit (también descubierto por qwertyoruiop) que llega hasta la versión 4.07 del software de sistema. Esto significa que una vez se ponga en marcha la forma de implementarlo, un método que debería ser idéntico al usado con el 4.05, los únicos que podrán aprovecharse de este avance serán los usuarios de una consola con firmware 4.06 y 4.07.

Cuando esto pase se ampliará la base de PlayStation 4 vulnerables y se podrá adaptar el homebrew enabler PS4HEN. Esto se traducirá en la posibilidad de usar las herramientas necesarias para volcar, descifrar, modificar y ejecutar respaldos de juegos cuyo requisito sea tener instalado el firmware 4.07.

A pesar de este avance hasta el software del sistema 4.07, los usuarios con una PlayStation 4 en la versión 4.05 que estén disfrutando de las bondades de la scene no deberían actualizar. Solo se recomendará hacerlo cuando exista la forma de implementar este nuevo exploit y todas las herramientas se ejecuten en la nueva versión.

Los jugadores con una PlayStation 4 con software del sistema 4.55 deberán esperar a que se publique un nuevo punto de entrada. Técnicamente encontrar una vulnerabilidad en el kernel es la parte más difícil, así que la posibilidad de que más pronto que tarde aparezca un exploit en el webkit (u otra vía) es muy alta. Todo parece indicar que de forma privada ya podría existir.

Para aquellos que estén en el firmware 5.01 la esperanza sigue abierta. Su turno llegará cuando el trabajo esté listo y se pueda hacer público.

Fuente: Elotrolado

Compartir